summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-09-03 05:13:36 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-09-03 23:00:35 +0300
commit948c700b90814918080b041690ebbf5cd687ae07 (patch)
treee09fa95f42e7257b194424d6becbb2ebefb3539a
parentd070a0884cd49068dc1acf6e225aa3ce487f015c (diff)
downloadguix-948c700b90814918080b041690ebbf5cd687ae07.tar.gz
gnu: Add emacs-pubmed.
* gnu/packages/emacs-xyz.scm (emacs-pubmed): New variable.

Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab13e8d306..be88802071 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9701,6 +9701,32 @@ included by default, and more can be readily added.")
       (description "This package provides functions for converting Unicode to ASCII.")
       (license license:gpl2+))))
 
+(define-public emacs-pubmed
+  (package
+    (name "emacs-pubmed")
+    (version "0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/fvdbeek/emacs-pubmed.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "15bwjxc7g43m5pi8z17anaqqkvi209r7kk1chmf175477gvrv7c0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-deferred" ,emacs-deferred)
+       ("emacs-esxml" ,emacs-esxml)
+       ("emacs-s" ,emacs-s)
+       ("emacs-unidecode" ,emacs-unidecode)))
+    (home-page "https://gitlab.com/fvdbeek/emacs-pubmed")
+    (synopsis "Interface to PubMed")
+    (description "This package provides an Emacs interface to the PubMed
+database of references on life sciences.")
+    (license license:gpl3+)))
+
 (define-public emacs-websocket
   (package
     (name "emacs-websocket")