summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:35 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit995443acacea93b3cec5aca364189c14aa370ea1 (patch)
treec35c6d5ac40658b7e94bfc9195553bb4aba3e6a4
parent04cf30e15323fa56c1f0ce7e4e8f3981dab9f99a (diff)
downloadguix-995443acacea93b3cec5aca364189c14aa370ea1.tar.gz
gnu: Add python-stsci-imagestats.
* gnu/packages/astronomy.scm (python-stsci-imagestats): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 80bf8a68f8..cba285816e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2073,6 +2073,31 @@ spherical polygons that represent arbitrary regions of the sky.")
 Science Institute} image array manipulation functions.")
     (license license:bsd-3)))
 
+(define-public python-stsci-imagestats
+  (package
+    (name "python-stsci-imagestats")
+    (version "1.6.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsci.imagestats" version))
+              (sha256
+               (base32
+                "14457izlbnks84dyza75ib3nvx2w8nhlqm9vc1zb7hbhknb5gjvw"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f)) ;No tests
+    (propagated-inputs (list python-numpy))
+    (native-inputs (list python-setuptools-scm))
+    (home-page "https://stsciimagestats.readthedocs.io/en/latest/")
+    (synopsis "Compute sigma-clipped statistics on data arrays")
+    (description
+     "@code{stsci.imagestats} is a package designed to compute various
+statistics on image data using sigma-clipping iterations.  It is designed to
+replicate core behaviour of the IRAF's
+@url{http://stsdas.stsci.edu/cgi-bin/gethelp.cgi?imstatistics, imstatistics
+task}.")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")