summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-28 19:22:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:34:25 +0100
commit9b02d1a11e75044d46e5341b47659d45b1ecb21f (patch)
tree10c23c222c867eac3a6abbcef47013a7c3328484
parent5df4e27fec27d20ab2c17691b2c5ff15ce8fb066 (diff)
downloadguix-9b02d1a11e75044d46e5341b47659d45b1ecb21f.tar.gz
gnu: Add r-rapportools.
* gnu/packages/cran.scm (r-rapportools): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c6fab7554e..ab93c833f8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6910,3 +6910,27 @@ directories or URLs with their associated programs.")
      "Run @code{R CMD check} from R programmatically, and capture the results
 of the individual checks.")
     (license license:expat)))
+
+(define-public r-rapportools
+  (package
+    (name "r-rapportools")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rapportools" version))
+       (sha256
+        (base32
+         "1sgv4sc737i12arh5dc3263kjsz3dzg06qihfmrqyax94mv2d01b"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-pander" ,r-pander)
+       ("r-plyr" ,r-plyr)
+       ("r-reshape" ,r-reshape)))
+    (home-page "https://cran.r-project.org/web/packages/rapportools/")
+    (synopsis "Miscellaneous helper functions with sane defaults for reporting")
+    (description
+     "This package provides helper functions that act as wrappers to more
+advanced statistical methods with the advantage of having sane defaults for
+quick reporting.")
+    (license license:agpl3+)))