summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
commit9bba3eb336f8cf3cd662f7d72e13e97d7d9e5561 (patch)
tree0a3202facd79a73511866b0b03da3f4671882f44
parent800fef714c12768d54507870798e1f7850be2f0b (diff)
downloadguix-9bba3eb336f8cf3cd662f7d72e13e97d7d9e5561.tar.gz
gnu: qxlsx: Fix include directory.
* gnu/packages/qt.scm (qxlsx)[source]: Add patch.
* gnu/packages/patches/qxlsx-fix-include-directory.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qxlsx-fix-include-directory.patch24
-rw-r--r--gnu/packages/qt.scm3
3 files changed, 27 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f10713f126..06a370eec6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1721,6 +1721,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/python-wxwidgets-type-errors.patch	\
   %D%/packages/patches/quodlibet-fix-invalid-glob.patch	\
   %D%/packages/patches/quodlibet-fix-mtime-tests.patch		\
+  %D%/packages/patches/qxlsx-fix-include-directory.patch	\
   %D%/packages/patches/scribus-1.5.8-poppler-22.03.0.patch	\
   %D%/packages/patches/scribus-1.5.8-poppler-22.04.0.patch	\
   %D%/packages/patches/scribus-1.5.8-poppler-22.09.0.patch	\
diff --git a/gnu/packages/patches/qxlsx-fix-include-directory.patch b/gnu/packages/patches/qxlsx-fix-include-directory.patch
new file mode 100644
index 0000000000..a68ca0cc3b
--- /dev/null
+++ b/gnu/packages/patches/qxlsx-fix-include-directory.patch
@@ -0,0 +1,24 @@
+From 8c3e6633e3c901bc5a5cd477383421b0980dcd26 Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <sokolov@google.com>
+Date: Mon, 17 Apr 2023 23:43:59 +0100
+Subject: [PATCH] Fix #278
+
+There's no real reason to install the same headers twice, but at least
+now clients of the library can build again
+---
+ QXlsx/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/QXlsx/CMakeLists.txt b/QXlsx/CMakeLists.txt
+index 4fa7f7f1..074922a8 100644
+--- a/QXlsx/CMakeLists.txt
++++ b/QXlsx/CMakeLists.txt
+@@ -179,7 +179,7 @@ PRIVATE
+     ${QXLSX_HEADERPATH}
+ PUBLIC
+     $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/header>
+-    $<INSTALL_INTERFACE:include/QXlsx>
++    $<INSTALL_INTERFACE:include/QXlsxQt${QT_VERSION_MAJOR}>
+ )
+ 
+ set_target_properties(QXlsx PROPERTIES
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7a82d94d90..a79338f84e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1129,7 +1129,8 @@ from within Qt 5.")))
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0xbpajvwkv09h2fang200nsanv5gl1alsdd725gh9cgq4szng6gj"))))
+        (base32 "0xbpajvwkv09h2fang200nsanv5gl1alsdd725gh9cgq4szng6gj"))
+       (patches (search-patches "qxlsx-fix-include-directory.patch"))))
     (build-system cmake-build-system)
     (arguments
      (list