summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 08:52:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:34 -0400
commita749fbea4e5f0f3faaff60b64625921225df2dbb (patch)
tree0c9fea2dac2c9dcc3ad68e0142ff9f456b186182
parentb391578a2447e677528d6684f424ab798b885dc0 (diff)
downloadguix-a749fbea4e5f0f3faaff60b64625921225df2dbb.tar.gz
gnu: python-faker: Update to 13.3.4 and honor TESTS?.
* gnu/packages/python-xyz.scm (python-faker): Update to 13.3.4.
[phases]{check}: Honor TESTS?.
[native-inputs]: Replace python-pytest-6 by python-pytest.  Remove comment.
[propagated-inputs]: Remove python-text-unidecode.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 176fa7ec28..43009da908 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17506,28 +17506,28 @@ parsing UK postcodes.")
 (define-public python-faker
   (package
     (name "python-faker")
-    (version "9.3.1")
+    (version "13.3.4")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "Faker" version))
               (sha256
                (base32
-                "0lpfdc4ndvk7chgqrfd2b1my4n54pccq9b645vp9cp5s5ypyknfd"))))
+                "04855dqvvi2mr739l5x3qf82rxq0a7spc8gl76k8xixmbw36328q"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _ (invoke "python" "-m" "pytest" "-v"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "pytest" "-v")))))))
     (native-inputs
-     (list ;; For testing
-           python-freezegun
-           python-pytest-6
+     (list python-freezegun
+           python-pytest
            python-random2
            python-ukpostcodeparser
            python-validators))
-    (propagated-inputs
-     (list python-dateutil python-text-unidecode))
+    (propagated-inputs (list python-dateutil))
     (home-page "https://github.com/joke2k/faker")
     (synopsis "Python package that generates fake data")
     (description