summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-01 17:39:29 -0400
committerLeo Famulari <leo@famulari.name>2016-07-03 22:24:44 -0400
commitafcb871954bcafff9aa5969a8a92777647ae2fef (patch)
tree899c39d6f982358d8ec134b348c203b0db0b61c7
parentd8fa9cf7f4173b1b30adc1a7b75f7dd46218c424 (diff)
downloadguix-afcb871954bcafff9aa5969a8a92777647ae2fef.tar.gz
gnu: Add python-alabaster.
* gnu/packages/python.scm (python-alabaster, python2-alabaster): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c9c782de13..da6dde5d3a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9700,3 +9700,30 @@ the PNG, JPEG, JPEG 2000, and GIF formats.")
       (native-inputs
        `(("python2-setuptools" ,python2-setuptools)
          ,@(package-native-inputs base))))))
+
+(define-public python-alabaster
+  (package
+    (name "python-alabaster")
+    (version "0.7.8")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "alabaster" version))
+              (sha256
+               (base32
+                "1zqz9hsvnmpjklmir6g7rxlv2fslrgsnwb91r9sgz4n1zja1pjx1"))))
+    (build-system python-build-system)
+    (synopsis "Default theme for the Sphinx documentation system")
+    (description "Alabaster is a responsive and configurable theme for the
+Sphinx documentation system.  It is compatible with Python 2 and 3, and it is
+the default Sphinx theme.")
+    (home-page "https://github.com/bitprophet/alabaster")
+    (license bsd-3)
+    (properties `((python2-variant . ,(delay python2-alabaster))))))
+
+(define-public python2-alabaster
+  (let ((base (package-with-python2 (strip-python2-variant python-alabaster))))
+    (package
+      (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))