summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:27:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:49 +0200
commitc0011a5d0b1d1160ebd4f02f5a545c498ab70e8c (patch)
tree99630f80a9198a183fb41d860dc6cc85f283b1f4
parent4c3237429436870cc7df57eadfe674f0a7bba6a3 (diff)
downloadguix-c0011a5d0b1d1160ebd4f02f5a545c498ab70e8c.tar.gz
gnu: texlive-listings: Refresh package definition.
* gnu/packages/tex.scm (texlive-listings): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-FANCYVRB, TEXLIVE-HYPERREF, TEXLIVE-URL.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index aebe698a5c..34fc53337b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6973,30 +6973,30 @@ TeX-paragraphs.  All the paragraphs are taken with permission from
     (license license:lppl1.3+)))
 
 (define-public texlive-listings
-  (let ((template
-         (simple-texlive-package
-          "texlive-listings"
-          (list "doc/latex/listings/"
-                "source/latex/listings/"
-                "tex/latex/listings/")
-          (base32 "15dnm0j86305x84ss3ymhhcczcw45b2liq01vrab6fj204wzsahk"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/listings")
-         ((#:build-targets _ '())
-          #~(list "listings.ins"))))
-      (home-page "https://www.ctan.org/pkg/listings")
-      (synopsis "Typeset source code listings using LaTeX")
-      (description
-       "The package enables the user to typeset programs (programming code)
+  (package
+    (name "texlive-listings")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/listings/" "source/latex/listings/"
+                   "tex/latex/listings/")
+             (base32
+              "15dnm0j86305x84ss3ymhhcczcw45b2liq01vrab6fj204wzsahk")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     ;; Do not build intermediate "lstdrvrs.ins".
+     (list #:build-targets '(list "listings.ins")))
+    (propagated-inputs
+     (list texlive-fancyvrb texlive-hyperref texlive-url))
+    (home-page "https://ctan.org/pkg/listings")
+    (synopsis "Typeset source code listings using LaTeX")
+    (description
+     "The package enables the user to typeset programs (programming code)
 within LaTeX; the source code is read directly by TeX---no front-end processor
 is needed.  Keywords, comments and strings can be typeset using different
 styles.  Support for @code{hyperref} is provided.")
-      (license license:lppl1.3+))))
+    (license license:lppl1.3+)))
 
 (define-public texlive-listingsutf8
   (package