summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-20 17:44:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-21 13:19:33 +0300
commitc11afc46777bfdf3dc222062cfe3518c0d8a657a (patch)
tree85b168a356599b9be0ba1efc928fc5932f6be5bd
parent696b22141cb53b9797c80f49079c0a0fcd60ba64 (diff)
downloadguix-c11afc46777bfdf3dc222062cfe3518c0d8a657a.tar.gz
gnu: libpaper: Skip tests when cross-compiling.
* gnu/packages/ghostscript.scm (libpaper)[arguments]: Adjust #:tests to
skip tests when cross-compiling.
-rw-r--r--gnu/packages/ghostscript.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 2d7f07fb40..502b41bb99 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -93,7 +93,8 @@ Consortium standard (ICC), approved as ISO 15076-1.")
                                  ;; Tests require a relocatable build.
                                  "--enable-relocatable")
            ;; --enable-relocate is broken on the Hurd
-           #:tests? (not (target-hurd?))))
+           #:tests? (not (or (target-hurd?)
+                             (%current-target-system)))))
     (outputs '("out" "debug"))
     (home-page "https://github.com/rrthomas/libpaper")
     (synopsis "Library for handling paper sizes")