summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:28:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:14 +0200
commitce749beb17e58481b24853030043b44c6c6d3e8f (patch)
tree301b3adf4b961142cb7dadcd06e3375bde04d06a
parentf35207fb1faba45bd5f83d7c0b57f7039a38eeb0 (diff)
downloadguix-ce749beb17e58481b24853030043b44c6c6d3e8f.tar.gz
gnu: Add texlive-accfonts.
* gnu/packages/tex.scm (texlive-accfonts): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7b44db18a1..54aa4ce60d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -988,6 +988,30 @@ ones.")
 (define-deprecated/alias texlive-union texlive-updmap.cfg)
 (export texlive-union)
 
+(define-public texlive-accfonts
+  (package
+    (name "texlive-accfonts")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/accfonts/" "scripts/accfonts/"
+                   "tex/latex/accfonts/")
+             (base32
+              "0kja24rh0ysljwgkyg9mf47h64ayi2kmb1jb3dmvb42ywvg0w9i7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "mkt1font" "vpl2ovp" "vpl2vpl")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/accfonts")
+    (synopsis "Utilities to derive new fonts from existing ones")
+    (description
+     "The @code{accfonts} package contains three utilities to permit easy
+manipulation of fonts, in particular the creation of unusual accented
+characters. @command{mkt1font} works on Adobe Type 1 fonts, @command{vpl2vpl}
+works on TeX virtual fonts and @command{vpl2ovp} transforms a TeX font to an
+Omega one.")
+    (license license:gpl3+)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")