summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:07 +0200
commitd2baed46796d2ed808d4a00e96087f97e3861e28 (patch)
tree1299d8a7c8e433671334c0f2960346e5f60d4386
parent296e9dc1efe954059d0acccbb37d23bc8a42b8e5 (diff)
downloadguix-d2baed46796d2ed808d4a00e96087f97e3861e28.tar.gz
gnu: wsdd: Fix cross-‘compilation’.
The copy-build-system appears unsuitable for scripts.

* gnu/packages/samba.scm (wsdd)[build-system]:
Switch to the GNU build system.
[arguments]: Replace #:install-plan with custom #:phases.
-rw-r--r--gnu/packages/samba.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b8ba9ed818..c8b8d03521 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -523,11 +523,25 @@ and IPV6 and the protocols layered above them, such as TCP and UDP.")
        (file-name (git-file-name name version))
        (sha256
         (base32 "16kk7x80jlargrvh643m23j277p0drs2yylqz54f9inf5ld5bxn5"))))
-    (build-system copy-build-system)
+    (build-system gnu-build-system)
     (arguments
-     '(#:install-plan
-       '(("src/wsdd.py" "bin/wsdd")
-         ("man/wsdd.8" "share/man/man8/"))))
+     (list
+      #:tests? #f                       ; no test suite, only examples
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)           ; no configure script
+          (delete 'build)               ; nothing to build
+          (replace 'install
+            (lambda _
+              (with-directory-excursion "src"
+                (rename-file "wsdd.py" "wsdd")
+                (install-file "wsdd" (string-append #$output "/bin")))
+              (for-each
+               (lambda (file)
+                 (install-file file
+                               (string-append #$output "/share/man/man"
+                                              (string-take-right file 1))))
+               (find-files "man" "\\.[0-9]$")))))))
     (inputs
      (list python))
     (home-page "https://github.com/christgau/wsdd")