summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-28 19:21:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:33:13 +0100
commitd6871153c8217f79cb2fe10a002eaaa9c4340e34 (patch)
treed2f65c12b1d2d871a4ba37db7c871dc07dab7b08
parent21405e81e7bf4016c4e8ed385186a94e8955bef7 (diff)
downloadguix-d6871153c8217f79cb2fe10a002eaaa9c4340e34.tar.gz
gnu: Add r-fs.
* gnu/packages/cran.scm (r-fs): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5e9973a071..bc99c3e6df 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6736,3 +6736,26 @@ back to file after modifications.")
     (description
      "This package provides a minimal R client to access the GitHub API.")
     (license license:expat)))
+
+(define-public r-fs
+  (package
+    (name "r-fs")
+    (version "1.2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fs" version))
+       (sha256
+        (base32
+         "0kqqaqqml8x3r1mdld40iwns0ylj2f52qsdh1vcn39f7w7c2ka8j"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://fs.r-lib.org")
+    (synopsis "Cross-platform file system operations based on libuv")
+    (description
+     "This package provides a cross-platform interface to file system
+operations, built on top of the libuv C library.")
+    (license license:gpl3)))