summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-10 02:27:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:52 -0400
commitdb3d093546c3babab9b29c4d50130361f53196f8 (patch)
treeb9157388d586ed1764373ee04cc626ac503601dc
parentbe1c940d3a833740c8ccc0e6da8ab8507514bb87 (diff)
downloadguix-db3d093546c3babab9b29c4d50130361f53196f8.tar.gz
gnu: gspell: Update to 1.11.1.
* gnu/packages/gnome.scm (gspell): Update to 1.11.1.
[source]: Delete patches.
[phases]{disable-problematic-tests}: New phase.
[native-inputs]: Remove labels.
* gnu/packages/patches/gspell-dash-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm31
-rw-r--r--gnu/packages/patches/gspell-dash-test.patch22
3 files changed, 19 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a733fc60de..9eb984dc66 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1243,7 +1243,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/groovy-add-exceptionutilsgenerator.patch	\
   %D%/packages/patches/grub-efi-fat-serial-number.patch		\
   %D%/packages/patches/grub-setup-root.patch			\
-  %D%/packages/patches/gspell-dash-test.patch			\
   %D%/packages/patches/gst-plugins-good-fix-test.patch		\
   %D%/packages/patches/guile-1.8-cpp-4.5.patch			\
   %D%/packages/patches/guile-2.2-skip-oom-test.patch            \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7184b50ab4..ed4305db90 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10838,7 +10838,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
 (define-public gspell
   (package
     (name "gspell")
-    (version "1.8.2")
+    (version "1.11.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -10846,13 +10846,18 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1miybm1z5cl91i25l7mfqlxhv7j8yy8rcgi0s1bgbb2vm71rb4dv"))
-              (patches (search-patches "gspell-dash-test.patch"))))
+                "14h2w0yzqwaw5dykmhh21sy2c96g17waahg2lxc52xqiyzis8spg"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      '(#:configure-flags (list "--enable-vala")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'disable-problematic-tests
+           (lambda _
+             (substitute* "testsuite/test-checker.c"
+               ;; This test is known to fail with Aspell, as a comment
+               ;; mentions it.  Disable it.
+               ((".*g_test_add_func.*test_dashes.*") ""))))
          (add-before 'check 'pre-check
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Tests require a running X server.
@@ -10869,18 +10874,20 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
     (inputs
      (list iso-codes))
     (native-inputs
-     `(("glib" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("pkg-config" ,pkg-config)
-       ("vala" ,vala)                             ;for VAPI, needed by Geary
-       ("xmllint" ,libxml2)
+     (list `(,glib "bin")
+           gobject-introspection
+           pkg-config
+           vala                         ;for VAPI, needed by Geary
+           libxml2
 
-       ;; For tests.
-       ("aspell-dict-en" ,aspell-dict-en)
-       ("xorg-server" ,xorg-server-for-tests)))
+           ;; For tests.
+           aspell-dict-en
+           xorg-server-for-tests))
     (propagated-inputs
      ;; Referred by .pc file.
-     (list enchant glib gtk+))
+     (list enchant
+           glib
+           gtk+))
     (home-page "https://wiki.gnome.org/Projects/gspell")
     (synopsis "GNOME's alternative spell checker")
     (description
diff --git a/gnu/packages/patches/gspell-dash-test.patch b/gnu/packages/patches/gspell-dash-test.patch
deleted file mode 100644
index 1c9d77cfba..0000000000
--- a/gnu/packages/patches/gspell-dash-test.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Somehow, Aspell 0.60.6.1 and aspell-dict-en-2016.11.20-0 don't consider
-this a valid spelling.  Skip it.
-
-TODO: Migrate to using hunspell. According to upstream, this bug won't be fixed.
-See https://bugzilla.gnome.org/show_bug.cgi?id=772406.
---- a/testsuite/test-checker.c	2017-03-24 09:50:50.000000000 -0400
-+++ b/testsuite/test-checker.c	2017-06-15 21:47:07.116173895 -0400
-@@ -105,10 +105,11 @@
- 	 * be considered deprecated, it is better to use hunspell, so WONTFIX.
- 	 * For more details, see:
- 	 * https://bugzilla.gnome.org/show_bug.cgi?id=772406
-+	 *
-+	 * correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
-+	 * g_assert_no_error (error);
-+	 * g_assert (correctly_spelled);
- 	 */
--	correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
--	g_assert_no_error (error);
--	g_assert (correctly_spelled);
- 
- 	correctly_spelled = gspell_checker_check_word (checker, "nrst-auie", -1, &error);
- 	g_assert_no_error (error);