summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:45:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:34 +0200
commitefde0718f86c17ad6a136adf5b2df16b998b2dc7 (patch)
tree97d07c10f90f40a58816c71db9a2f2f84ea2e130
parent34e2e55a1a19252d9b1e872d49e2f34a8c371631 (diff)
downloadguix-efde0718f86c17ad6a136adf5b2df16b998b2dc7.tar.gz
gnu: texlive-biblatex-apa: Refresh package definition.
* gnu/packages/tex.scm (texlive-biblatex-apa): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d89a396c60..ef51938951 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10839,23 +10839,22 @@ section.
 
 (define-public texlive-biblatex-apa
   (package
-    ;; Version 9.16 2022-06-22
-    (inherit (simple-texlive-package
-              "texlive-biblatex-apa"
-              (list "doc/latex/biblatex-apa/"
-                    "tex/latex/biblatex-apa/")
-              (base32
-               "0ivf7xbzj4xd57sqfbi87hbr73rraqifkzvx06yxgq0gmzz0x6wl")
-              #:trivial? #t))
-    (propagated-inputs
-     (list texlive-biblatex biber texlive-csquotes))
-    (home-page
-     "https://www.ctan.org/pkg/biblatex-apa")
+    (name "texlive-biblatex-apa")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/biblatex-apa/"
+                   "tex/latex/biblatex-apa/")
+             (base32
+              "0ivf7xbzj4xd57sqfbi87hbr73rraqifkzvx06yxgq0gmzz0x6wl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/biblatex-apa")
     (synopsis "BibLaTeX citation and reference style for APA")
     (description
      "This is a fairly complete BibLaTeX style (citations and references) for
-@acronym{APA, American Psychological Association} publications.  It implements
-and automates most of the guidelines in the APA 7th edition style guide for
+APA (American Psychological Association) publications.  It implements and
+automates most of the guidelines in the APA 7th edition style guide for
 citations and references.")
     (license license:lppl1.3c)))