summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:06:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:45 +0200
commitfd1ac474b79cb458f51b461d896d0afd0b3f7860 (patch)
tree81a00d3fba596b388f162e34c5d128860a68c49c
parentfde679ba8392582e7994f954d00f12c8a3d4d1a2 (diff)
downloadguix-fd1ac474b79cb458f51b461d896d0afd0b3f7860.tar.gz
gnu: Add texlive-termmenu.
* gnu/packages/tex.scm (texlive-termmenu): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 66f5747290..284fd6c9d0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3737,6 +3737,28 @@ required.")
 position is already further along, @code{\\tabto} starts a new line.")
     (license license:public-domain)))
 
+(define-public texlive-termmenu
+  (package
+    (name "texlive-termmenu")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/termmenu/"
+                   "source/generic/termmenu/"
+                   "tex/generic/termmenu/")
+             (base32
+              "0d1pdz5izr43ndji7g28932dnnf8d6nxvh8bay2yk7647yh47aj4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/termmenu")
+    (synopsis "Support for terminal-based menus")
+    (description
+     "When writing programs, it's often required to present the user with
+a list of options or actions.  The user is then expected to select one of
+these options for the program to process.  @code{termmenu} provides this
+mechanism for TeX.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")