summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:06:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:44 +0200
commitfde679ba8392582e7994f954d00f12c8a3d4d1a2 (patch)
tree8df5457b39d7d5f84a6406188f9d5a20291aa575
parent04968722d76b758c079ffba35a9d333900fe2183 (diff)
downloadguix-fde679ba8392582e7994f954d00f12c8a3d4d1a2.tar.gz
gnu: Add texlive-tabto-generic.
* gnu/packages/tex.scm (texlive-tabto-generic): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 61700ff363..66f5747290 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3719,6 +3719,24 @@ aligned vertically.  The package works with plain TeX or LaTeX, but e-TeX is
 required.")
     (license license:lppl1.3c)))
 
+(define-public texlive-tabto-generic
+  (package
+    (name "texlive-tabto-generic")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "tex/generic/tabto-generic/")
+             (base32
+              "0i65jflbnhqpqf1w7pkagicic1s39gcl319z7g9zr1g80f9532dv")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tabto-generic")
+    (synopsis "Tab to a measured position in the line")
+    (description
+     "@code{\\tabto@{<length>@}} moves the typesetting position to
+@code{<length>} from the left margin of the paragraph.  If the typesetting
+position is already further along, @code{\\tabto} starts a new line.")
+    (license license:public-domain)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")