summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:40:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:34 +0200
commitfe3f7a1b92e842dfbf712e06c20129ecb985f523 (patch)
tree76434637585b64679b8efc4539f18c493ebbd387
parentfd198a23f358bf329c0fe1f9f3755a2bcc95c06b (diff)
downloadguix-fe3f7a1b92e842dfbf712e06c20129ecb985f523.tar.gz
gnu: texlive-units: Refresh package definition.
* gnu/packages/tex.scm (texlive-units): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0291109c7c..723f10373e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10880,22 +10880,24 @@ of the visual appearance.")
       (license license:lppl1.3+))))
 
 (define-public texlive-units
-  (let ((template (simple-texlive-package
-                   "texlive-units"
-                   (list "/doc/latex/units/"
-                         "/tex/latex/units/")
-                   (base32
-                    "1ia1vzy8dp7pdvmawwnmh9lmkajmpnnh62dixrjpb6mnxq118bfd")
-                   #:trivial? #t)))
-    (package
-      (inherit template)
-      (home-page "http://www.ctan.org/pkg/units")
-      (synopsis "Typeset physical units and fractions")
-      (description "@code{units} is a package for typesetting physical
-units in a standard-looking way.  The package is based upon
-@code{nicefrac}, a package for typing fractions.  @code{nicefrac} is
-included in the @code{units} bundle.")
-      (license license:gpl3+))))
+  (package
+    (name "texlive-units")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/units/" "source/latex/units/"
+                   "tex/latex/units/")
+             (base32
+              "1mrdsg55f40cvarrx84gbhrnsk8mlv915nll17lnfzfapgmvjsbl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/units")
+    (synopsis "Typeset physical units and fractions")
+    (description "@code{units} is a package for typesetting physical units in
+a standard-looking way.  The package is based upon @code{nicefrac}, a package
+for typing fractions.  @code{nicefrac} is included in the @code{units}
+bundle.")
+    (license license:gpl3+)))
 
 (define-public texlive-microtype
   (package