summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:47 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commit00a81298033937ca9b9f0c686069db29074eb644 (patch)
treef6087f787b66a8928c3fe604fe2b54d8feaadb52
parente18b43ae38b90cb63be228886289eda24da00965 (diff)
downloadguix-00a81298033937ca9b9f0c686069db29074eb644.tar.gz
gnu: Add trytond-sale-supply-drop-shipment.
* gnu/packages/tryton.scm (trytond-sale-supply-drop-shipment): New variable.
-rw-r--r--gnu/packages/tryton.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4117c925b5..fb927698f7 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3614,6 +3614,38 @@ shipments.  If the purchase is cancelled the sale goes back to the default
 supply method.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-supply-drop-shipment
+  (package
+    (name "trytond-sale-supply-drop-shipment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_supply_drop_shipment" version))
+       (sha256
+        (base32 "0gm2m5zm7vrm1vb34svqby7h91ka3mhln3367zmwr17yfyqf68dk"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_supply_drop_shipment"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-purchase-request" ,trytond-purchase-request)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-supply" ,trytond-sale-supply)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-sale-supply-drop-shipment")
+    (synopsis "Tryton module for sale supply drop shipment")
+    (description "The @emph{Sale Supply Drop Shipment} Tryton module adds a
+drop shipment option on product supplier if \"supply on request\" is checked.
+When checked, the purchase request and the linked purchase have the address of
+customer as Delivery Address; at the confirmation of the purchase a drop
+shipment is created and linked to both the purchase and the sale.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")