summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-23 18:16:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-06-27 12:47:43 +0300
commit015cd2e86e779907085d356c69b6091dc8ac1788 (patch)
tree720d26ebda53431f91f9c63597614dd742c45126
parent84f662bf4bf23d2818acea3fdb0c30f2d91e6b7c (diff)
downloadguix-015cd2e86e779907085d356c69b6091dc8ac1788.tar.gz
gnu: rust-stackvector: Update to 1.1.1 [fixes CVE-2021-29939].
* gnu/packages/mail.scm (rust-stackvector-1): Update to 1.1.1.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 82a09b8b2a..4266709b7b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43303,7 +43303,7 @@ deeply recursive algorithms that may accidentally blow the stack.")
 (define-public rust-stackvector-1
   (package
     (name "rust-stackvector")
-    (version "1.0.6")
+    (version "1.1.1")
     (source
      (origin
        (method url-fetch)
@@ -43312,7 +43312,7 @@ deeply recursive algorithms that may accidentally blow the stack.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1bv820fhdad16islwli1g3iksk39ivf0zaqz4j1m08vq15jjaiqw"))))
+         "0xnz2z9hvn8h1hb3fq9mpf0ibw4g9pk54wpqis0knj329cfhz3zl"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t