summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 10:33:17 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:54 +0800
commit0dc25538be09a49c34220ada2fd79377c206d09b (patch)
treed71f291179ebb1a803562a64cbec44185a9f438d
parentbc89baeffe24fb38961ab050df778c95a34e63e2 (diff)
downloadguix-0dc25538be09a49c34220ada2fd79377c206d09b.tar.gz
gnu: lxqt-policykit: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-policykit): Update to 1.1.0.
[arguments]: Remove phases.
-rw-r--r--gnu/packages/lxqt.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index aee43b32bb..da2a1f5cce 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -568,14 +568,14 @@ of other programs.")
 (define-public lxqt-policykit
   (package
     (name "lxqt-policykit")
-    (version "0.17.0")
+    (version "1.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "119bjhx208g7wxmr8r0ajb3wl6vagq1aks6zz07df4bgjs3nnpli"))))
+        (base32 "150ggcfprascnwgsz721vnmay9cbar9annlhp6h2yzkl69iyc49r"))))
     (build-system cmake-build-system)
     (inputs
      (list kwindowsystem
@@ -588,23 +588,7 @@ of other programs.")
            qtx11extras))
     (native-inputs
      (list pkg-config polkit lxqt-build-tools qttools-5))
-    (arguments
-     '(#:tests? #f                      ; no test target
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-source
-           (lambda _
-             (substitute* '("autostart/CMakeLists.txt")
-               (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
-                "DESTINATION \"etc/xdg"))
-             #t))
-         (add-after 'unpack 'patch-translations-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "CMakeLists.txt"
-               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
-                (string-append (assoc-ref outputs "out")
-                               "/share/lxqt/translations")))
-             #t)))))
+    (arguments '(#:tests? #f))          ; no test target
     (home-page "https://lxqt-project.org")
     (synopsis "The LXQt PolicyKit agent")
     (description "lxqt-policykit is the polkit authentication agent of