summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 00:35:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:44 -0400
commit0f446f1bc4cfc0752faa49efcd11914d7b4e977c (patch)
tree82a3b2af6c6f856ff8bcae3ed05a54125237d986
parent8194b36ddf34fdae110c7feb5b3c7c3a97c6e42a (diff)
downloadguix-0f446f1bc4cfc0752faa49efcd11914d7b4e977c.tar.gz
gnu: python-ipyparallel: Update to 8.2.1.
* gnu/packages/python-xyz.scm (python-ipyparallel-bootstrap): Update to 8.2.1.
[propagated-inputs]: Add python-entrypoints, python-psutil and python-tqdm.
Update python-tornado to version 6.
(python-ipyparallel)[phases]{check}: Override phase.
[native-inputs]: Remove python-mock and python-nose.  Add
python-pytest-asyncio and python-pytest-tornado.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7055b58094..b573a7cd15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8787,14 +8787,14 @@ away.")
   (hidden-package
    (package
      (name "python-ipyparallel-bootstrap")
-     (version "6.2.4")
+     (version "8.2.1")
      (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "ipyparallel" version))
         (sha256
          (base32
-          "0rf0dbpxf5z82bw8lsjj45r3wdd4wc74anz4wiiaf2rbjqlb1ivn"))))
+          "0wiwfd7870zbmczzn96jqxxjf2zcbcaxnsl1ddn8hspwa8y4frzj"))))
      (build-system python-build-system)
      (arguments
       (list
@@ -8806,12 +8806,14 @@ away.")
      (propagated-inputs
       (list python-dateutil
             python-decorator
-            ;; python-ipykernel is omitted here to avoid a cycle.
+            python-entrypoints
             python-ipython
-            python-ipython-genutils
+            ;; python-ipykernel is omitted here to break a cycle.
             python-jupyter-client-bootstrap
+            python-psutil
             python-pyzmq
-            python-tornado
+            python-tornado-6
+            python-tqdm
             python-traitlets))
      (home-page "https://ipython.org/")
      (synopsis "Interactive Parallel Computing with IPython")
@@ -8830,13 +8832,19 @@ CLI scripts:
   (package
     (inherit python-ipyparallel-bootstrap)
     (name "python-ipyparallel")
-    (arguments (list #:tests? #t))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda _
+              (invoke "pytest" "-vv"))))))
     (native-inputs
      (list python-ipython
-           python-mock
-           python-nose
            python-pytest
+           python-pytest-asyncio
            python-pytest-cov
+           python-pytest-tornado
            python-testpath))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs python-ipyparallel-bootstrap)