summary refs log tree commit diff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-13 18:39:06 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:37 +0200
commit10059113431fc6fdbcd94351e14881af5dda907c (patch)
treef6c22527333abda31b13f9cab361c1858ce2749c
parent8c5891d50ba90b1e00edd445e1cf9ab1e1e4a449 (diff)
downloadguix-10059113431fc6fdbcd94351e14881af5dda907c.tar.gz
gnu: po4a: Skip failing test on the Hurd.
* gnu/packages/gettext.scm (po4a)[arguments]: When building natively on the
Hurd, add phase 'skip-tests/hurd'.
-rw-r--r--gnu/packages/gettext.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 947bffe3ba..b3dd844147 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -279,7 +279,14 @@ from Markdown files.")
           (add-before 'check 'disable-failing-tests
             (lambda _
               ;; FIXME: fails despite of importing SGMLS
-              (delete-file "t/fmt-sgml.t"))))))
+              (delete-file "t/fmt-sgml.t")))
+          #$@(if (system-hurd?)
+                 #~((add-after 'unpack 'skip-tests/hurd
+                      (lambda _
+                        (delete-file "t/cfg-multi.t")
+                        (delete-file "t/cfg-single.t")
+                        (delete-file "t/cfg-split.t"))))
+                 #~()))))
     (native-inputs
      (list gettext-minimal
            perl-module-build