summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-31 17:36:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-01 00:13:55 +0100
commit1872c00df50d64c82172a25276a0fa5334922931 (patch)
tree63e1fcef3c31af22bc2c9a2e774497ac08419a29
parent2ff28472e3bc1d2f3df3794bfa98102d00f65a22 (diff)
downloadguix-1872c00df50d64c82172a25276a0fa5334922931.tar.gz
gnu: python-binwalk: Rename to binwalk.
* gnu/packages/python-xyz.scm (binwalk): New variable renamed from
(python-binwalk): this old thing.  Redefine it using DEPRECATED-PACKAGE.
* gnu/packages/diffoscope.scm (diffoscope)[native-inputs]: Adjust accordingly.
-rw-r--r--gnu/packages/diffoscope.scm2
-rw-r--r--gnu/packages/python-xyz.scm7
2 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index dfb2e05f16..5a227d059e 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -156,9 +156,9 @@
               ("xxd" ,xxd)))
     (native-inputs `(("help2man" ,help2man)
                      ;; Below are modules used for tests.
+                     ("binwalk" ,binwalk)
                      ("python-pytest" ,python-pytest)
                      ("python-chardet" ,python-chardet)
-                     ("python-binwalk" ,python-binwalk)
                      ("python-black" ,python-black)
                      ("python-h5py" ,python-h5py)
                      ("python-pypdf2" ,python-pypdf2)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f12cca9757..2793b25f07 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16440,9 +16440,9 @@ binary or text.")
        `(("python2-enum34" ,python2-enum34)
          ,@(package-propagated-inputs base))))))
 
-(define-public python-binwalk
+(define-public binwalk
   (package
-    (name "python-binwalk")
+    (name "binwalk")
     (version "2.2.0")
     (source
      (origin
@@ -16475,6 +16475,9 @@ binary or text.")
 extracting firmware images")
     (license license:expat)))
 
+(define-public python-binwalk
+  (deprecated-package "python-binwalk" binwalk))
+
 (define-public python-nltk
   (package
     (name "python-nltk")