summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-23 19:33:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-11-19 04:04:46 +0100
commit188e3e2e6878346b0bdc8b46084f458abe86826c (patch)
treef9affda494efc0d93d85edb4342ecb82146529ba
parent9d662021aec7f89ea134d21ac379b9d471ee49e1 (diff)
downloadguix-188e3e2e6878346b0bdc8b46084f458abe86826c.tar.gz
gnu: ocaml4.07-merlin: Remove package.
* gnu/packages/ocaml.scm (ocaml4.07-merlin): Remove package.
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cc694d7376..8c83cbca9c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4648,34 +4648,6 @@ External contributors added support for Visual Studio Code, Sublime Text and
 Atom.")
     (license license:expat)))
 
-;; ocaml-merlin 3.4.2 can not be built with old version of dune used in
-;; package-with-ocaml4.07
-(define-public ocaml4.07-merlin
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-merlin)
-     (name "ocaml-merlin")
-     (version "3.2.2")
-     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-              (url "https://github.com/ocaml/merlin")
-              (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "15ssgmwdxylbwhld9p1cq8x6kadxyhll5bfyf11dddj6cldna3hb"))))
-     (build-system dune-build-system)
-     (inputs
-      `(("ocaml-yojson" ,ocaml-yojson)))
-     (native-inputs
-      `(("ocaml-findlib" ,ocaml-findlib)))
-     (arguments
-      `(#:package "merlin"
-        ;; Errors in tests in version 3.2.2
-        #:tests? #f)))))
-
 (define-public ocaml4.07-gsl
   (package
     (name "ocaml4.07-gsl")