summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2016-12-27 21:52:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-29 19:54:59 +0100
commit294304169a5ecc6efbb581102b871c4646c34966 (patch)
tree7cfcdd1715efde61ac7999df5a44277d809e6758
parent649d0c48411f9d03bfd5a0a7719903ecf70f4196 (diff)
downloadguix-294304169a5ecc6efbb581102b871c4646c34966.tar.gz
gnu: Add r-ggbeeswarm.
* gnu/packages/statistics.scm (r-ggbeeswarm): New variable.
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 52db18c29a..22485a8263 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3873,3 +3873,26 @@ closely-packed, non-overlapping points.")
 tokenization of R code, and helpers for interacting with the tokenized
 representation of R code.")
     (license license:expat)))
+
+(define-public r-ggbeeswarm
+  (package
+    (name "r-ggbeeswarm")
+    (version "0.5.3")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "ggbeeswarm" version))
+              (sha256
+               (base32
+                "1jgp55rvmzc4agcrlsjn8m5lk85di9c4wj94xzikqkql4lvq3qpd"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-beeswarm" ,r-beeswarm)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-vipor" ,r-vipor)))
+    (home-page "https://github.com/eclarke/ggbeeswarm")
+    (synopsis "Categorical scatter (violin point) plots")
+    (description
+     "This package provides two methods of plotting categorical scatter plots
+such that the arrangement of points within a category reflects the density of
+data at that region, and avoids over-plotting.")
+    (license license:gpl2+)))