summary refs log tree commit diff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:40 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:49 +0200
commit35f033750f5f0d8b1a46887f595319dd393c2f6c (patch)
treee38f1376af54aaf89c832d62309882c280ca4355
parent8e79e3dd3d325586684ec4c79d6d1400fa85966f (diff)
downloadguix-35f033750f5f0d8b1a46887f595319dd393c2f6c.tar.gz
gnu: Add r-parsnip.
* gnu/packages/cran.scm (r-parsnip): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f47bc63f72..8ee609e412 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24054,3 +24054,38 @@ vignettes in all common formats.")
      "This is a package for text mining for word processing and sentiment
 analysis using @code{dplyr}, @code{ggplot2}, and other Tidy tools.")
     (license license:expat)))
+
+(define-public r-parsnip
+  (package
+    (name "r-parsnip")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "parsnip" version))
+       (sha256
+        (base32
+         "1p33absjd2lnq5aikr42him4b724qzxr1pzvdnazg789f763i47l"))))
+    (properties `((upstream-name . "parsnip")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-dplyr" ,r-dplyr)
+       ("r-generics" ,r-generics)
+       ("r-globals" ,r-globals)
+       ("r-glue" ,r-glue)
+       ("r-magrittr" ,r-magrittr)
+       ("r-prettyunits" ,r-prettyunits)
+       ("r-purrr" ,r-purrr)
+       ("r-rlang" ,r-rlang)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyr" ,r-tidyr)
+       ("r-vctrs" ,r-vctrs)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://parsnip.tidymodels.org")
+    (synopsis "Common API to modeling and analysis functions")
+    (description
+     "This package provides a common interface to allow users to specify a
+model without having to remember the different argument names across different
+functions or computational engines (e.g. R, Spark, Stan, etc).")
+    (license license:gpl2)))