summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-03 14:28:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-03 14:32:01 -0400
commit448de3966eef81fe62999c7d728f7a458ab7bf86 (patch)
tree5e69f90680ff08fd67b47fb0c994516932a34d78
parente1ddcf75bf9e68a04698733063dd35a3d5b997ee (diff)
downloadguix-448de3966eef81fe62999c7d728f7a458ab7bf86.tar.gz
gnu: zchunk: Patch references to the 'zstd' command line tool.
Fixes https://issues.guix.gnu.org/49795.

* gnu/packages/compression.scm (zchunk)
[phases]{patch-paths}: New phase.
[inputs]: Add zstd.
[propagated-inputs]: Relabel the zstd "lib" as "zstd:lib".

Reported-by: Christopher Howard <christopher@librehacker.com>
-rw-r--r--gnu/packages/compression.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 26cddb12fa..ecc767a3bf 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2361,12 +2361,21 @@ reading from and writing to ZIP archives. ")
                (base32
                 "0nlzwnv6wh2yjyyv27f81jnvmk7psgpbnw7dsdp7frfkya569hgv"))))
     (build-system meson-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'patch-paths
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "src/zck_gen_zdict.c"
+                        (("/usr/bin/zstd")
+                         (string-append (assoc-ref inputs "zstd")
+                                        "/bin/zstd"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("curl" ,curl)))
+     `(("curl" ,curl)
+       ("zstd" ,zstd)))
     (propagated-inputs
-     `(("zstd" ,zstd "lib")))           ;in Requires.private of zck.pc
+     `(("zstd:lib" ,zstd "lib")))       ;in Requires.private of zck.pc
     (home-page "https://github.com/zchunk/zchunk")
     (synopsis "Compressed file format for efficient deltas")
     (description "The zchunk compressed file format allows splitting a file