summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-11-14 11:28:25 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2022-11-14 11:28:25 +0100
commit4cc746820a4043c029e26926f85c5e3c1d1b9eb3 (patch)
tree5cd641a3b25d25f803855965686030a7c663552e
parentf73d9690ad692653548457d4ab108b5200ef4d9b (diff)
downloadguix-4cc746820a4043c029e26926f85c5e3c1d1b9eb3.tar.gz
gnu: bbswitch-module: Update to 20220529 and fix for Linux 5.18+.
* gnu/packages/linux.scm (bbswitch-module): Update to 20220529 and fix for
Linux 5.18+.
[source]: Switch to fork since fix is not merged upstream yet.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 846f60a671..f87e591454 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1442,19 +1442,22 @@ emulate optical devices such as DVD and CD-ROM drives.")
 (define-public bbswitch-module
   ;; Use "develop" branch since stable release does not build on Linux >= 5.6.
   ;; See https://github.com/Bumblebee-Project/bbswitch/issues/205.
-  (let ((commit "ddbd243638c7bc2baecf43a78aff46cdc12e9b2e"))
+  (let ((commit "19f60204596a6463b162fc7ca11f4946f5c20cea"))
     (package
       (name "bbswitch-module")
-      (version (git-version "0.8" "1" commit))
+      (version (git-version "0.8" "2" commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/Bumblebee-Project/bbswitch")
+                      ;; Use fork until
+                      ;; https://github.com/Bumblebee-Project/bbswitch/pull/219
+                      ;; is merged.
+                      (url "https://github.com/madchic/bbswitch")
                       (commit commit)))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1pgldnza7mzd0flrxg4q69dwbq1fhl58m5c62ary5drb0xyf3lqb"))))
+                  "1pv41y02c9xg9k1bg4i4ll3w7hxxzdr651i08f092b9q5hr57mqn"))))
       (build-system linux-module-build-system)
       (arguments
        (list #:tests? #f))              ; no test suite