summary refs log tree commit diff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-03-03 10:11:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-04-04 10:32:01 +0200
commit4d336ecf200e1011eed6433f4a74e3fa7272b3af (patch)
tree43a6c450a4dd66d81a314160d78d2e788abf2a2c
parentaed1f47c4dc8b3dfa5728fd0651f9cd1a898a554 (diff)
downloadguix-4d336ecf200e1011eed6433f4a74e3fa7272b3af.tar.gz
gnu: Add python-bip39.
* gnu/packages/python-xyz.scm (python-bip39): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5304b6915e..60a13906d1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1262,6 +1262,29 @@ and verifies that it matches the intended target hostname.")
 for working with bidirectional mappings in Python.")
     (license license:mpl2.0)))
 
+(define-public python-bip39
+  (package
+    (name "python-bip39")
+    (version "0.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "bip39" version))
+       (sha256
+        (base32 "18m7d3gi7vj2zi0bl1z7m0nhcj6i8j9vj4vil276siagnpkv64ry"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/de-centralized-systems/python-bip39/")
+    (synopsis "Self-contained and simple BIP39 implementation in Python")
+    (description
+     "This package provides a self-contained and simple BIP39
+implementation written in Python.  It includes a @code{bip39.py} executable.
+
+BIP39 is a standardized mapping between binary data (the @emph{entropy}),
+and a list of words that are easier to remember for humans (the
+@emph{mnemonic}).")
+    (license license:expat)))
+
 (define-public python-bitarray
   (package
     (name "python-bitarray")