summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-24 09:49:56 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-24 09:49:56 +0100
commit55d3bd84a16b67613332e06f207e15e6e8394f5e (patch)
tree10c3ffeb4631a62c30d85f37f89fc55cbb0cd165
parent1151a16ed1b8591f571edb65ce0ab337bb11e693 (diff)
downloadguix-55d3bd84a16b67613332e06f207e15e6e8394f5e.tar.gz
gnu: emacs-org-jira: Run tests.
* gnu/packages/emacs-xyz.scm (emacs-org-jira)[arguments]: Run tests.
-rw-r--r--gnu/packages/emacs-xyz.scm50
1 files changed, 30 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8cfc8026b7..eb87d78894 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31492,27 +31492,37 @@ contains a track position, playback will start at the specified position.")
 
 (define-public emacs-org-jira
   (package
-   (name "emacs-org-jira")
-   (version "4.4.1")
-   (source
-    (origin
-     (method git-fetch)
-     (uri (git-reference
-           (url "https://github.com/ahungry/org-jira")
-           (commit version)))
-     (file-name (git-file-name name version))
-     (sha256
-      (base32
-       "1pkqyvziwp2573hnr8s41chsbm40564f76i3l8ynjr7955nccsms"))))
-   (build-system emacs-build-system)
-   (propagated-inputs
-    (list emacs-dash emacs-org emacs-request))
-   (home-page "https://github.com/ahungry/org-jira")
-   (synopsis "Syncing between Jira and Org mode")
-   (description
-    "This package provides an extension to Org mode for syncing issues with
+    (name "emacs-org-jira")
+    (version "4.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ahungry/org-jira")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1pkqyvziwp2573hnr8s41chsbm40564f76i3l8ynjr7955nccsms"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:tests? #true
+      #:test-command #~(list "emacs" "-Q" "--batch"
+                             "-l" "jiralib.el"
+                             "-l" "org-jira-sdk.el"
+                             "-l" "org-jira.el"
+                             "-l" "t/org-jira-t.el"
+                             "-l" "t/jiralib-t.el"
+                             "-f" "ert-run-tests-batch-and-exit")))
+    (propagated-inputs
+     (list emacs-dash emacs-org emacs-request))
+    (home-page "https://github.com/ahungry/org-jira")
+    (synopsis "Syncing between Jira and Org mode")
+    (description
+     "This package provides an extension to Org mode for syncing issues with
 JIRA issue servers.")
-   (license license:gpl3+)))
+    (license license:gpl3+)))
 
 (define-public emacs-slime-volleyball
   (package