summary refs log tree commit diff
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-06-07 21:54:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-07 21:55:39 +0200
commit5a42df6e49a2eae412d2a4d3c76668f486f5e5c3 (patch)
treecf65421eebb3576375dce5525bb619edaf121eff
parent8e6228d49906ad24dcaaf8b3b5a130e911cc022d (diff)
downloadguix-5a42df6e49a2eae412d2a4d3c76668f486f5e5c3.tar.gz
gnu: Add emacs-xah-fly-keys.
* gnu/packages/emacs-xyz.scm (emacs-xah-fly-keys): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e188df12cb..bb5af77422 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1939,6 +1939,28 @@ can be referred to during the expression.  This technique can improve clarity
 in certain cases.  It also enables recursion for anonymous functions.")
     (license license:public-domain)))
 
+(define-public emacs-xah-fly-keys
+  (package
+    (name "emacs-xah-fly-keys")
+    (version "17.13.20220526011611")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/xahlee/xah-fly-keys")
+                    (commit "b1b1ea62c3f1a329376d9125592175cf2027ebc7")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gv8d9zgmhzjg6zk2a7y76dz30a3l91xb1p15vldka95faz197wn"))))
+    (build-system emacs-build-system)
+    (home-page "http://xahlee.info/emacs/misc/ergoemacs_vi_mode.html")
+    (synopsis "Modal keybinding system for Emacs, based on command frequency and
+ergonomics")
+    (description "xah-fly-keys.el is a modal editing mode for Emacs, like Vi,
+but the design of key/command choice is based on command frequency statistics
+and ease-of-key score.  Most frequently used commands have most easy keys.")
+    (license license:gpl3)))
+
 (define-public emacs-xr
   (package
     (name "emacs-xr")