summary refs log tree commit diff
diff options
context:
space:
mode:
authorParnikkapore <poomklao@yahoo.com>2023-01-03 21:49:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-03 21:56:53 +0100
commit5dcf82452ff2585e44758279cf0eecdef4e4f732 (patch)
treea31ca11d483f71f12dc67da1750245c84f752ea3
parentf9cd9ed8691ca0c8112c32ea85304c09e1845cfa (diff)
downloadguix-5dcf82452ff2585e44758279cf0eecdef4e4f732.tar.gz
gnu: dbus: Add dbus to inputs.
* gnu/packages/stenography.scm (plover): Add dbus to inputs and
LD_LIBRARY_PATH.  Plover tries to load dbus during startup (visible
with --log-level debug).  This will allow it to find it.
[inputs]: Add dbus.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/stenography.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
index 56930dd37a..f95910dcff 100644
--- a/gnu/packages/stenography.scm
+++ b/gnu/packages/stenography.scm
@@ -28,12 +28,13 @@
   #:use-module (guix packages)
   #:use-module (gnu packages)
   #:use-module (gnu packages bash)
-  #:use-module (gnu packages qt)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages wxwidgets))
 
 (define-public python-plover-stroke
@@ -85,7 +86,9 @@
             (lambda* (#:key inputs #:allow-other-keys)
               (wrap-program (string-append #$output "/bin/plover")
                 `("QT_PLUGIN_PATH" prefix
-                  ,(list (search-input-directory inputs "/lib/qt5/plugins/")))))))))
+                  (,(search-input-directory inputs "/lib/qt5/plugins/")))
+                `("LD_LIBRARY_PATH" prefix
+                  (,(string-append #$(this-package-input "dbus") "/lib")))))))))
     (native-inputs
      (list python-babel
            python-mock
@@ -94,6 +97,7 @@
            python-pytest-xvfb))
     (inputs
      (list bash-minimal
+           dbus
            python-appdirs
            python-dbus
            python-hidapi