summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-14 13:21:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-14 13:21:59 +0200
commit7e303658d70e6af97d5bf967db6ee17e4cf23871 (patch)
tree560114f742c9d5bd2f5d9938e9ee354a8273ff6e
parent68ccd1a0d800d824bc5163e206f9227596f7da32 (diff)
downloadguix-7e303658d70e6af97d5bf967db6ee17e4cf23871.tar.gz
gnu: codingquarry: Use G-expression.
* gnu/packages/bioinformatics.scm (codingquarry)[arguments]: Use G-expression
to simplify 'install phase.  Install files to /share/codingquarry prefix.
[native-search-paths]: Adjust prefix.
[native-inputs]: Move python-2 from here...
[inputs]: ...to here.
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 990bdb28da..86696d7c14 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3446,31 +3446,31 @@ setup"))))
                 "0115hkjflsnfzn36xppwf9h9avfxlavr43djqmshkkzbgjzsz60i"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ; no "check" target
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (doc (string-append out "/share/doc/codingquarry")))
-               (install-file "INSTRUCTIONS.pdf" doc)
-               (copy-recursively "QuarryFiles"
-                                 (string-append out "/QuarryFiles"))
-               (install-file "CodingQuarry" bin)
-               (install-file "CufflinksGTF_to_CodingQuarryGFF3.py" bin))
-             #t)))))
-    (inputs (list openmpi))
+     (list
+      #:tests? #f                       ;no "check" target
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (replace 'install
+            (lambda _
+              (let ((bin (string-append #$output "/bin"))
+                    (doc (string-append #$output "/share/doc/codingquarry")))
+                (install-file "INSTRUCTIONS.pdf" doc)
+                (copy-recursively "QuarryFiles"
+                                  (string-append #$output
+                                                 "/share/codingquarry/QuarryFiles"))
+                (install-file "CodingQuarry" bin)
+                (install-file "CufflinksGTF_to_CodingQuarryGFF3.py" bin)))))))
+    ;; TODO: This package also needs a Python 2 variant of biopython
+    (inputs (list openmpi python-2)) ;Only Python 2 is supported
     (native-search-paths
      (list (search-path-specification
             (variable "QUARRY_PATH")
-            (files '("QuarryFiles")))))
-    (native-inputs `(("python" ,python-2))) ; Only Python 2 is supported
+            (files '("share/codingquarry/QuarryFiles")))))
+    (home-page "https://sourceforge.net/projects/codingquarry/")
     (synopsis "Fungal gene predictor")
     (description "CodingQuarry is a highly accurate, self-training GHMM fungal
 gene predictor designed to work with assembled, aligned RNA-seq transcripts.")
-    (home-page "https://sourceforge.net/projects/codingquarry/")
     (license license:gpl3+)))
 
 (define-public clustal-omega