summary refs log tree commit diff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-06-02 13:28:05 -0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-04 08:58:40 +0200
commit8334e7c36ba7266fdbcf783d80c02a072cf1347b (patch)
treea978033340a64f8c5b25f054d99092987010846a
parentc950d3ffe120a040bf5ab21db9d2eab89912aeac (diff)
downloadguix-8334e7c36ba7266fdbcf783d80c02a072cf1347b.tar.gz
gnu: Add emacs-color-theme-modern.
* gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0fd55c6931..0707a7d4a5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -110,6 +110,7 @@
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8464,6 +8465,30 @@ transparent background.  If you load it from a GUI, it will default to a
 dark background.")
     (license license:gpl3+)))
 
+(define-public emacs-color-theme-modern
+  ;; No release since October 2019
+  (let ((commit "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")
+        (revision "1"))
+    (package
+      (name "emacs-color-theme-modern")
+      (version (git-version "0.0.3" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/emacs-jp/replace-colorthemes.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacs-jp/replace-colorthemes")
+      (synopsis "Emacs color themes implemented via built-in customization")
+      (description "This package contains several themes that were originally
+implemented with the venerable @code{color-themes} package, ported to Emacs'
+built-in custom themes.")
+      (license license:gpl3+))))
+
 (define-public emacs-gruvbox-theme
   (package
     (name "emacs-gruvbox-theme")