summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:34 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit97a07e7467801e82c035098d610000057f569a4c (patch)
treec50687edff902dca19233e602df9493b869f3eba
parenta948453c9f5a36b4891bad69e7133211b0c7320d (diff)
downloadguix-97a07e7467801e82c035098d610000057f569a4c.tar.gz
gnu: Add trytond-purchase-request-quotation.
* gnu/packages/tryton.scm (trytond-purchase-request-quotation): New variable.
-rw-r--r--gnu/packages/tryton.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 1c5456529a..0e197bac2f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2842,6 +2842,37 @@ generated by other process from Tryton.")
   (deprecated-package
    "python-trytond-purchase-request" trytond-purchase-request))
 
+(define-public trytond-purchase-request-quotation
+  (package
+    (name "trytond-purchase-request-quotation")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_request_quotation" version))
+       (sha256
+        (base32 "12r34fawdsvxhaygs5nlnmx2a51x6yn0vgayj4qy083f4lv0mwml"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_request_quotation"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-purchase-requisition" ,trytond-purchase-requisition)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-party" ,trytond-party)
+       ("trytond-product" ,trytond-product)
+       ("trytond-purchase-request" ,trytond-purchase-request)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-purchase-request-quotation")
+    (synopsis "Tryton module for purchase request quotation")
+    (description "The @emph{Purchase Request Quotation} Tryton module allows
+users to ask quotations from selected purchase requests to different
+suppliers.  Each request will collect quotation information from the
+supplier.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")