summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:35 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit9c5930fe9714c1b076e7bc78b612a29e35bc4b9d (patch)
tree878d854df02858cdac6b84fc928bc0a39960f9c6
parent26ed7052120a868b8c89ed5fc27b2c35ad44caa4 (diff)
downloadguix-9c5930fe9714c1b076e7bc78b612a29e35bc4b9d.tar.gz
gnu: Add trytond-purchase-secondary-unit.
* gnu/packages/tryton.scm (trytond-purchase-secondary-unit): New variable.
-rw-r--r--gnu/packages/tryton.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index fbdfb27fcc..4bef8f4267 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2904,6 +2904,40 @@ typically is the purchasing department.  On approval, purchase requests will
 be created.")
     (license license:gpl3+)))
 
+(define-public trytond-purchase-secondary-unit
+  (package
+    (name "trytond-purchase-secondary-unit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_secondary_unit" version))
+       (sha256
+        (base32 "0vyvdrshlikp9m3gxn1yyi15qxgih0cccxndr9d257fap9nilip5"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_secondary_unit"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-invoice-secondary-unit"
+        ,trytond-account-invoice-secondary-unit)
+       ("trytond-stock-secondary-unit" ,trytond-stock-secondary-unit)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-product" ,trytond-product)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-purchase-secondary-unit")
+    (synopsis "Tryton module to add a secondary unit on purchase line")
+    (description "The @emph{Purchase Secondary Unit} Tryton module adds a
+secondary unit of measure on purchase lines.
+
+The secondary quantity and unit price are kept synchronized with the quantity
+and unit price.  The secondary unit is defined on the product supplier or on
+the product with its factor against the purchase unit.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")