summary refs log tree commit diff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-04-04 20:16:09 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-08 23:32:34 +0200
commitab4d1c26121ef27503b5239bc682b6f131302092 (patch)
treed89eb7699aeec3610ae350ec525cfa4377de933f
parentadc671450babead42c54a09fcb756118eb6741c6 (diff)
downloadguix-ab4d1c26121ef27503b5239bc682b6f131302092.tar.gz
gnu: Add emacs-pass.
* gnu/packages/emacs.scm (emacs-pass): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ac69cfa397..cb722844cc 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7494,6 +7494,30 @@ used with SGML-like languages: XML, HTML, XHTML, XSL, etc.")
 standard Unix password manager\").")
     (license license:gpl2+)))
 
+(define-public emacs-pass
+  (package
+    (name "emacs-pass")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/NicolasPetton/pass/archive/"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0zlx9v6z0q3w9qhq9bq6vb7sli4c9x7qccm2wq55j0nw7bwy2yvj"))
+              (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-password-store" ,emacs-password-store)
+       ("emacs-f" ,emacs-f)))
+    (home-page "https://github.com/NicolasPetton/pass")
+    (synopsis "Major mode for @file{password-store.el}")
+    (description "This is a major mode for managing password-store (pass)
+keychains.  The keychain entries are displayed in a directory-like structure
+and can be consulted and modified.")
+    (license license:gpl3+)))
+
 (define-public emacs-evil-anzu
   (package
     (name "emacs-evil-anzu")