summary refs log tree commit diff
diff options
context:
space:
mode:
authorTomasz Jeneralczyk <tj@schwi.pl>2022-06-28 16:15:47 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-02 13:49:35 +0200
commitb02225b614f94f3532e4ba220e175a83a0019dae (patch)
treef64c3d94aaafd9673b7d13e32299d7d910f8bca2
parentaaf4694b9fddf3ab392e367fc0bfd93ca64bed7d (diff)
downloadguix-b02225b614f94f3532e4ba220e175a83a0019dae.tar.gz
gnu: Add gdk-pixbuf-xlib.
This was part of gtk-pixbuf before but was split into its own library
in version 2.42.0: https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0

* gnu/packages/gtk.scm (gtk-pixbuf-xlib): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gtk.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4d6a690fbb..358eb365ef 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -717,6 +717,34 @@ scaled, composited, modified, saved, or rendered.")
     (home-page "https://wiki.gnome.org/Projects/GdkPixbuf")
     (license license:lgpl2.1+)))
 
+(define-public gdk-pixbuf-xlib
+  (package
+    (name "gdk-pixbuf-xlib")
+    (version "2.40.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vwnvqxap3r9zw932jwasazy9sxw49j78x2g650xkn70iili90bg"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:configure-flags '("-Dgtk_doc=true")))
+    (native-inputs (list pkg-config gtk-doc/stable))
+    (inputs (list gdk-pixbuf libx11))
+    (synopsis "Deprecated Xlib integration for GdkPixbuf")
+    (description
+     "GdkPixbuf-Xlib contains the deprecated API for integrating GdkPixbuf with
+Xlib data types.  This library was originally shipped by gdk-pixbuf, and has
+since been moved out of the original repository.  No newly written code should
+ever use this library.")
+    (home-page "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib")
+    (license license:lgpl2.1+)))
+
 ;;; A minimal variant used to prevent a cycle with Inkscape.
 (define-public at-spi2-core-minimal
   (hidden-package