summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-10 23:08:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-10 23:08:30 +0300
commitbbf3497c37f7ca63d0bfad7beea969e83b4338af (patch)
treeb736e25ab5a4bdc72d0482253b2424760f5e051c
parentd7827c941eb057b04453341d9d5756500dee6421 (diff)
downloadguix-bbf3497c37f7ca63d0bfad7beea969e83b4338af.tar.gz
gnu: Add rust-clang-ast-0.1.
* gnu/packages/crates-io.scm (rust-clang-ast-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e7f3aa7eb2..71d3385501 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7289,6 +7289,34 @@ coding.")
      "This package provides current CI environment information.")
     (license license:asl2.0)))
 
+(define-public rust-clang-ast-0.1
+  (package
+    (name "rust-clang-ast")
+    (version "0.1.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "clang-ast" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "1sfqyxszas78s78nga88fl0i5qlr87qsj22vlxarhvx96q86impf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t     ; Uses unstable features.
+       #:cargo-inputs
+       (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-clang-ast-test-suite" ,rust-clang-ast-test-suite-0.0.0)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/dtolnay/clang-ast")
+    (synopsis "Data structures for processing Clang's ast format")
+    (description "This package contains data structures for processing Clang's
+@code{-ast-dump=json} format.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-clang-ast-test-suite-0.0.0
   (package
     (name "rust-clang-ast-test-suite")