summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:42:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:20 +0200
commitbdfc3cfd11de3fbee038b47d40f8c1a9579c418a (patch)
tree2e65a1c10b80bd0451e31f2867874719b78edae8
parent8227084dbe2041a4e4c24b6a69cb278cd4aeaaa0 (diff)
downloadguix-bdfc3cfd11de3fbee038b47d40f8c1a9579c418a.tar.gz
gnu: Add texlive-abstyles.
* gnu/packages/tex.scm (texlive-abstyles): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index be0548cf88..3e03abc13a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1109,6 +1109,32 @@ Plain TeX or LaTeX.  It allows writing, e.g., @samp{\\<TEX>} instead of
 parameterless macros.")
     (license license:public-domain)))
 
+(define-public texlive-abstyles
+  (package
+    (name "texlive-abstyles")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bib/abstyles/"
+                   "bibtex/bst/abstyles/"
+                   "doc/bibtex/abstyles/"
+                   "tex/generic/abstyles/")
+             (base32
+              "1ij4cp3pydfs4lch0f93gi2q7msafxyqfvv44whw1ppczidicnn2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/abstyles-orig")
+    (synopsis "Adaptable BibTeX styles")
+    (description
+     "This package provides a family of modifications of the standard BibTeX
+styles whose behaviour may be changed by changing the user document, without
+change to the styles themselves.  The package is largely used nowadays in its
+adaptation for working with Babel.")
+    (license
+     (list license:isc                  ;apreamble
+           license:knuth                ;bxabst
+           license:public-domain))))    ;docmac
+
 (define-public texlive-adhocfilelist
   (package
     (name "texlive-adhocfilelist")