summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-25 15:46:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:41:35 +0200
commitc7e31cde04f6308615734f5c6fd91de87e1a60f5 (patch)
treeb723bc383be9d53b24a5a3daa22e59709259e8f3
parent6a2e54236e1b2c428c8fd478ee0f3bd8130703fa (diff)
downloadguix-c7e31cde04f6308615734f5c6fd91de87e1a60f5.tar.gz
gnu: ftgl: Update to 2.4.0.
* gnu/packages/gl.scm (ftgl): Update to 2.4.0.
[home-page]: Change to maintained fork at <https://github.com/frankheckenbach/ftgl>.
[source]: Change to GIT-FETCH.
[native-inputs]: Add AUTOCONF, AUTOMAKE and LIBTOOL.
-rw-r--r--gnu/packages/gl.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index f615ebd71c..e7d50a5b8a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -149,15 +149,16 @@ the X-Consortium license.")
 (define-public ftgl
   (package
     (name "ftgl")
-    (version "2.1.3-rc5")
+    (version "2.4.0")
+    (home-page "https://github.com/frankheckenbach/ftgl")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://sourceforge/ftgl/FTGL%20Source/2.1.3~rc5/"
-                    "ftgl-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference (url home-page)
+                                  (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0nsn4s6vnv5xcgxcw6q031amvh2zfj2smy1r5mbnjj2548hxcn2l"))))
+                "0zjs1h9w30gajq9lndzvjsa26rsmr1081lb1fbpbj10yhcdcsc79"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--disable-static")))
@@ -167,8 +168,10 @@ the X-Consortium license.")
               ("mesa" ,mesa)
               ("glu" ,glu)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (home-page "http://ftgl.sourceforge.net")
+     `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
     (synopsis "Font rendering library for OpenGL applications")
     (description
      "FTGL is a font rendering library for OpenGL applications.  Supported