summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-13 21:54:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:52 +0200
commitcb1f6878c190da135d718d47a6184e2efa992b4a (patch)
tree36989aa42d8a85effbf277ee3b703db5741d40d8
parent8bc31f951b438d569756af6c432ee6100d0ffa05 (diff)
downloadguix-cb1f6878c190da135d718d47a6184e2efa992b4a.tar.gz
gnu: julia-specialfunctions: Update to 1.8.7.
* gnu/packages/julia-xyz.scm (julia-specialfunctions): Update to 1.8.7.
[propagated-inputs]: Add julia-irrationalconstants.
-rw-r--r--gnu/packages/julia-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 87424eea88..c9a270c653 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5265,7 +5265,7 @@ timsort and radixsort.")
 (define-public julia-specialfunctions
   (package
     (name "julia-specialfunctions")
-    (version "1.6.0")
+    (version "1.8.7")
     (source
      (origin
        (method git-fetch)
@@ -5274,12 +5274,13 @@ timsort and radixsort.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0nfpnglx7zl9g20w2mgfkg17hcw9ri0shaq2rwplj0ij5pwz8yf0"))))
+        (base32 "0shlgx9lkbjb1awdf5lrbkq06bmkyahc92qay2a049b4lvqrhj7a"))))
     (build-system julia-build-system)
     (inputs
      (list julia-chainrulestestutils))
     (propagated-inputs
      (list julia-chainrulescore
+           julia-irrationalconstants
            julia-logexpfunctions
            julia-openspecfun-jll))
     (home-page "https://github.com/JuliaMath/SpecialFunctions.jl")