summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 13:55:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:37 +0100
commitce4b7a44366b0d40699c082fbfa8d985681187c7 (patch)
treeaea2b664f714e6703ebc7a91ff7ade4eba76df15
parentddacd13d564b38ac2cb3fee7aa6372790d033b2c (diff)
downloadguix-ce4b7a44366b0d40699c082fbfa8d985681187c7.tar.gz
gnu: python-zope-i18nmessageid: Update to 5.0.1.
* gnu/packages/python-web.scm (python-zope-i18nmessageid): Update to 5.0.1.
[native-inputs]: Add PYTHON-COVERAGE and PYTHON-ZOPE-TESTRUNNER.
[propagated-inputs]: Add PYTHON-SIX.
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 176e54a6ac..848d5856b5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1092,15 +1092,20 @@ tests.")
 (define-public python-zope-i18nmessageid
   (package
     (name "python-zope-i18nmessageid")
-    (version "4.0.3")
+    (version "5.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "zope.i18nmessageid" version))
        (sha256
         (base32
-         "1rslyph0klk58dmjjy4j0jxy21k03azksixc3x2xhqbkv97cmzml"))))
+         "0ndhn4w1qgwkfbwf9vm2bgq418z5g0wmfsgl0d9nz62cd0mi8d4m"))))
     (build-system python-build-system)
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-zope-testrunner" ,python-zope-testrunner)))
+    (propagated-inputs
+     `(("python-six" ,python-six)))
     (home-page "https://pypi.org/project/zope.i18nmessageid/")
     (synopsis "Message identifiers for internationalization")
     (description "Zope.i18nmessageid provides facilities for declaring