summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:48 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commitd25221af4ec451382ed82912d3310d6e82da17f5 (patch)
treea8057ab670817dd5b170af2741ca9329f6ab0fbd
parent5d191a04f465b443f3306a4f03abe8b339ffa1b8 (diff)
downloadguix-d25221af4ec451382ed82912d3310d6e82da17f5.tar.gz
gnu: Add trytond-stock-consignment.
* gnu/packages/tryton.scm (trytond-stock-consignment): New variable.
-rw-r--r--gnu/packages/tryton.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index dad11f66b5..1d163823bc 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3731,6 +3731,37 @@ on shipments and production that allows you to decide from which precise
 location to pick products.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-consignment
+  (package
+    (name "trytond-stock-consignment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_consignment" version))
+       (sha256
+        (base32 "0c2wa0d8msam77nd4c79f71jaznsprnlvv1jqrmkl1qf3lvgq4a2"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_consignment"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-stock-supply" ,trytond-stock-supply)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-invoice-line-standalone"
+        ,trytond-account-invoice-line-standalone)
+       ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
+       ("trytond-product" ,trytond-product)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-consignment")
+    (synopsis "Tryton module to manage consignment stock")
+    (description "The @emph{Stock Consignment} Tryton module allow to manage
+consignment stock from supplier or at customer warehouse.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")