summary refs log tree commit diff
diff options
context:
space:
mode:
authorVincent Prat <vprat@deeplinks.com>2022-04-22 10:15:59 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-04-27 11:28:37 +0200
commitde61e4908557290c94656c49a71465e7eab17318 (patch)
tree018596b2452d7691668541163593f3b7b4866a3f
parent090b3823b86b6c7123527c61e7f092e641c3b7d8 (diff)
downloadguix-de61e4908557290c94656c49a71465e7eab17318.tar.gz
gnu: Add python-mike.
* gnu/packages/python-xyz.scm (python-mike): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..a3a8734cbd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29534,3 +29534,26 @@ match a given regular expression, or count possible matches efficiently. It
 uses the parsed regular expression, so you get a much more accurate result
 than trying to just split strings.")
     (license license:asl2.0)))
+
+(define-public python-mike
+  (package
+    (name "python-mike")
+    (version "1.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "mike" version))
+              (sha256
+               (base32
+                "0yxp816x7s948xsd0fifvq9shg01xdxlifd9rzf5y2rd9iwz3hsn"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-coverage python-flake8 python-shtab))
+    (propagated-inputs
+     (list python-jinja2 python-mkdocs python-pyyaml python-verspec))
+    (home-page "https://github.com/jimporter/mike")
+    (synopsis "Manage multiple versions of MkDocs-powered documentation")
+    (description
+     "This package provides a Python utility to easily deploy multiple
+versions of MkDocs-powered docs to a Git branch.  It is suitable for deploying
+to Github via gh-pages.")
+    (license license:bsd-3)))