summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-21 21:58:04 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-21 21:58:04 +0100
commitec3b1c575d2d866646920490e849c4a0c708df60 (patch)
treed2fc7b23027bca21236f98a09d96721423d450c5
parentcf87cc894d6913e5c58a381890f920d7e1edf178 (diff)
downloadguix-ec3b1c575d2d866646920490e849c4a0c708df60.tar.gz
gnu: Use 'glibc-utf8-locales-final' in the default patching inputs.
* gnu/packages/commencement.scm (glibc-utf8-locales-final): Make public.
* guix/packages.scm (%standard-patch-inputs): Use
  GLIBC-UTF8-LOCALES-FINAL instead of GLIBC-UTF8-LOCALES.
-rw-r--r--gnu/packages/commencement.scm2
-rw-r--r--guix/packages.scm3
2 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index f312e1729c..d96a8237c3 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -616,7 +616,7 @@ store.")
                                  (current-source-location)
                                  #:guile %bootstrap-guile)))
 
-(define glibc-utf8-locales-final
+(define-public glibc-utf8-locales-final
   ;; Now that we have GUILE-FINAL, build the UTF-8 locales.  They are needed
   ;; by the build processes afterwards so their 'scm_to_locale_string' works
   ;; with the full range of Unicode codepoints (remember
diff --git a/guix/packages.scm b/guix/packages.scm
index f12ef99b3e..69cfd6d26c 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -336,7 +336,8 @@ corresponds to the arguments expected by `set-path-environment-variable'."
       ("gzip"  ,(ref '(gnu packages compression) 'gzip))
       ("lzip"  ,(ref '(gnu packages compression) 'lzip))
       ("patch" ,(ref '(gnu packages base) 'patch))
-      ("locales" ,(ref '(gnu packages base) 'glibc-utf8-locales)))))
+      ("locales" ,(ref '(gnu packages commencement)
+                       'glibc-utf8-locales-final)))))
 
 (define (default-guile)
   "Return the default Guile package used to run the build code of