summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-16 17:16:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-16 19:36:23 +0200
commitef8c91be7f92fe0a4c10ad6ff33fe479f297895a (patch)
treeee6160ebc786bc81482f4ebbed221184306908bf
parent0441e834a26d4442e27db5aad729d7869b3ee7b8 (diff)
downloadguix-ef8c91be7f92fe0a4c10ad6ff33fe479f297895a.tar.gz
gnu: rust-filetime-0.2: Don't hide package.
* gnu/packages/crates-io.scm (rust-filetime-0.2)[arguments]: Skip build.
Add rust-cfg-if-0.1, rust-libc-0.2, rust-redox-syscall-0.1,
rust-winapi-0.3 to cargo-inputs. Add rust-tempdir-0.3 to
cargo-development-inputs.
[properties]: Remove field.
-rw-r--r--gnu/packages/crates-io.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aa5ae7fba2..3a9e013446 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2956,6 +2956,15 @@ provides implementations for @code{HashMap} and @code{HashSet}.")
          (base32
           "0sflihq2l77xjrza7yjalnxsc7dxzg25rhzcfbd9vmyfah5kimvb"))))
     (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-0.1)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-redox-syscall" ,rust-redox-syscall-0.1)
+        ("rust-winapi" ,rust-winapi-0.3))
+       #:cargo-development-inputs
+       (("rust-tempdir" ,rust-tempdir-0.3))))
     (home-page "https://github.com/alexcrichton/filetime")
     (synopsis "Platform-agnostic accessors of timestamps in File metadata")
     (description
@@ -2964,7 +2973,6 @@ various timestamps of files in Rust.  This library takes into account
 cross-platform differences in terms of where the timestamps are located, what
 they are called, and how to convert them into a platform-independent
 representation.")
-    (properties '((hidden? . #t)))
     (license (list license:asl2.0
                    license:expat))))