summary refs log tree commit diff
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-04-06 20:07:28 +0000
committerLudovic Courtès <ludo@gnu.org>2018-04-11 01:03:46 +0200
commitf8fbe376549d10dd409b93d61129bc6c15d0fd1d (patch)
tree8f2c75aeeb12e4d69f051c53970bfb03acfb04c1
parent395541b0182f828103fc7f9edec2bb59616bb112 (diff)
downloadguix-f8fbe376549d10dd409b93d61129bc6c15d0fd1d.tar.gz
gnu: Add qBittorrent.
* gnu/packages/bittorrent.scm (qBittorrent): New public variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/bittorrent.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index b168f88e08..c6b9d74f33 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -53,6 +54,7 @@
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xml))
@@ -408,4 +410,45 @@ focusing on efficiency and scalability.  It runs on embedded devices as well as
 desktops.")
     (license l:bsd-2)))
 
+(define-public qbittorrent
+  (package
+    (name "qbittorrent")
+    (version "4.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/qbittorrent/qBittorrent/archive/release-"
+                    version ".tar.gz"))
+              (file-name (string-append name "-release-" version ".tar.gz"))
+              (sha256
+               (base32
+                "145r4lv7rqdhrm5znn3ndxsfdf579n46zvj7c53c422am8ir5xhp"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-boost-libdir="
+                            (assoc-ref %build-inputs "boost")
+                            "/lib")
+             "--enable-debug"
+             "QMAKE_LRELEASE=lrelease")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("boost" ,boost)
+       ("libtorrent-rasterbar" ,libtorrent-rasterbar)
+       ("openssl" ,openssl)
+       ("python" ,python)
+       ("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("zlib" ,zlib)))
+    (home-page "https://www.qbittorrent.org/")
+    (synopsis "Graphical BitTorrent client")
+    (description
+     "qBittorrent is a BitTorrent client programmed in C++/Qt that uses
+libtorrent (sometimes called libtorrent-rasterbar) by Arvid Norberg.
 
+It aims to be a good alternative to all other BitTorrent clients out there.
+qBittorrent is fast, stable and provides unicode support as well as many
+features.")
+    (license l:gpl2+)))