summary refs log tree commit diff
diff options
context:
space:
mode:
authorHugo Lecomte <hugo.lecomte@inria.fr>2021-07-05 09:29:30 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:51 +0200
commitfaa26f2342fc652ef6c7b13303b7fafb65c3db10 (patch)
tree82e0ac4ec636d995cf87df8921084a298dba1222
parent885c1bd06ec8212f3882bf81ff0900a7fadda735 (diff)
downloadguix-faa26f2342fc652ef6c7b13303b7fafb65c3db10.tar.gz
gnu: Add python-pydata-sphinx-theme.
* gnu/packages/sphinx.scm (python-pydata-sphinx-theme): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/sphinx.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 8928b795f4..6f1656eb82 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -49,7 +49,9 @@
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
-  #:use-module (gnu packages time))
+  #:use-module (gnu packages time)
+  #:use-module (gnu packages python-science)
+  #:use-module (gnu packages graph))
 
 (define-public python-sphinx
   (package
@@ -837,3 +839,40 @@ automated way to document command-line programs.  It scans
 @code{argparse.ArgumentParser} object, and then expands it into a set of
 @code{.. program::} and @code{.. option::} directives.")
     (license license:bsd-2)))
+
+(define-public python-pydata-sphinx-theme
+  (package
+    (name "python-pydata-sphinx-theme")
+    (version "0.6.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pydata-sphinx-theme" version))
+       (sha256
+        (base32
+         "055bh3hyh72pafiylvgpsjlk18wm15gg4azc5rjlsww5z475iq1j"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-beautifulsoup4" ,python-beautifulsoup4)))
+    (native-inputs
+     `(("python-beautifulsoup4" ,python-beautifulsoup4)
+       ("python-docutils" ,python-docutils)
+       ("python-jupyter-sphinx" ,python-jupyter-sphinx)
+       ("python-numpy" ,python-numpy)
+       ("python-numpydoc" ,python-numpydoc)
+       ("python-pandas" ,python-pandas)
+       ("python-plotly" ,python-plotly)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-regressions"
+        ,python-pytest-regressions)
+       ("python-recommonmark" ,python-recommonmark)
+       ("python-sphinx" ,python-sphinx)
+       ("python-xarray" ,python-xarray)
+       ("python-docutils" ,python-docutils)
+       ("python-sphinx" ,python-sphinx)))
+    (home-page "https://github.com/pydata/pydata-sphinx-theme")
+    (synopsis "Bootstrap-based Sphinx theme")
+    (description
+     "This package provides a Bootstrap-based Sphinx theme from the PyData
+community.")
+    (license license:bsd-3)))