summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-07 10:50:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-07 10:50:11 +0100
commitfb3dfff677e5610897fd0154d764aa9ec208c2e3 (patch)
tree989d311ae8fa0d71fab2cfcdca319d68ab0770c1
parentf46b962b7eef877d219c640af92ab1473fd3d364 (diff)
downloadguix-fb3dfff677e5610897fd0154d764aa9ec208c2e3.tar.gz
gnu: azr3: Use Gexp.
* gnu/packages/audio.scm (azr3)[arguments]: Use Gexp to dispose of %output
references.
-rw-r--r--gnu/packages/audio.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f47da1c37d..132a1018ce 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1106,13 +1106,14 @@ formant warp.")
                                        "azr3-remove-lash.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; no check target
-       #:make-flags
-       (list "LV2PEG=ttl2c"
-             (string-append "prefix=" %output)
-             (string-append "pkgdatadir=" %output "/share/azr3-jack"))
-       #:phases
-       (modify-phases %standard-phases
+     (list
+      #:tests? #f ; no check target
+      #:make-flags
+      #~(list "LV2PEG=ttl2c"
+              (string-append "prefix=" #$output)
+              (string-append "pkgdatadir=" #$output "/share/azr3-jack"))
+      #:phases
+      '(modify-phases %standard-phases
          (add-before 'install 'fix-timestamp
            (lambda _
              (let ((early-1980 315619200)) ; 1980-01-02 UTC