summary refs log tree commit diff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-08-25 12:09:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-12-29 23:23:35 +0100
commitfc23100030e2640dc8b1077db38fe8ab541b9dc4 (patch)
treef6702d55ff00fe642fa0e9218699afe362b95346
parentf030d0433f1e3dc0b95623022c24e416eaed83c6 (diff)
downloadguix-fc23100030e2640dc8b1077db38fe8ab541b9dc4.tar.gz
gnu: Add r-climaemet.
* gnu/packages/cran.scm (r-climaemet): New variable.
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2f744fd6d5..bb1ecfdf65 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1124,6 +1124,39 @@ isolated functions, also called crates, print to the console with their total
 size and can be easily tested locally before being sent to a remote.")
     (license license:gpl3)))
 
+(define-public r-climaemet
+  (package
+    (name "r-climaemet")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "climaemet" version))
+              (sha256
+               (base32
+                "1z0i8iz7f32kns8j1yb3sp2m0zhl4pgp4bf52aiqykjp9i791dqm"))))
+    (properties `((upstream-name . "climaemet")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-dplyr
+           r-ggplot2
+           r-httr
+           r-jsonlite
+           r-rappdirs
+           r-readr
+           r-rlang
+           r-tibble
+           r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://ropenspain.github.io/climaemet/")
+    (synopsis "Climate AEMET Tools")
+    (description
+     "This package provides tools to download the climatic data of the Spanish
+Meteorological Agency (AEMET) directly from R using their API and create
+scientific graphs (climate charts, trend analysis of climate time series,
+temperature and precipitation anomalies maps, warming stripes graphics,
+climatograms, etc.).")
+    (license license:gpl3)))
+
 (define-public r-climatol
   (package
     (name "r-climatol")